Irony in VS2010 (.NET 4.0)

Aug 18, 2010 at 7:42 AM
Edited Aug 18, 2010 at 7:44 AM

Hi all,

First let me say that this is really a great project!

I'm trying to get Irony running in VS2010. I was able to adopt the Language template from VS2008 to VS2010. After some small modifications I was able to compile it. The Grammar explorer is working well.

Then I tried to start a new VS2010 Hive with the Language Service. But I wasn't successful.

VS2010 comes up but no code highlighting / checks / completions at all.

I think this is an issue while using target framework .NET 3.5!?

I tried to change it to 4.0, changed some reference libs - but no luck getting it work. (No compile errors, but the Grammar Explorer blames about System.BadImageFormatException)...

 

Anyway - is there a Irony lib available for VS2010? Was anybody successful getting it run with VS2010 Hive?

Thanks in advance.

 

Regards,

wonder123

Coordinator
Aug 19, 2010 at 8:26 AM

I did not start moving to VS2010 yet, so can't say what's wrong. Try to debug it and see where it breaks.

Make sure you upgrade all project References to .NET 4.0 libraries