Version for Framework 3.5

Sep 20, 2011 at 10:01 PM


I know that my question might be weird but I tried to recompile version Irony-2011-09-13 in .NET 3.5 but this does not work (unknown libraries in 3.5).

Since my current development in entirely in 3.5, and 4.0 gives me some incompatibilities (and worst performance), I was wondering whether someone still had a .NET 3.5 version somewhere....

Between us, I only use Irony in the context of "FullTextSearch" (google-like) SQL translation for European languages (FR, EN, IT, ES, DE, PT, NL). [version Irony-51617 did not work with accentuated characters).

In advance, many thanks


Sep 20, 2011 at 10:15 PM

take the version from July, it has 3.5 projects:

sorry, had to abandon 3.5, as ExpressionType enum is much shorter in previous version - and I already went too far coding for .NET 4 extended values set.


Sep 20, 2011 at 10:34 PM

Thanks a lot.  

Before I received your answer, I tried with "ae65832df6cd" (28AUG2011) but I wasn't sure this was a stable version.

You don't have to apologize at all.  You are going ahead while I am obliged to keep on working with 3.5

Wonderful work you did!  Congratulations.