Which the last compilable version?

Jul 8, 2009 at 7:17 AM

I try to compile the last version, downloading the zip file, but in VS 2008 SP1 Italian version, don't compile the projects. I don't known why.
I think to modify a set of source (stable) for refactoring about write style identation, etc, add some comments /// ... ///  and use for my project about an VS IDE integration for Atmel AVR Simulator project...

Can I help you about source refactoring?

So, the next stable version? (beta or RC)?

Thank you.

Riccardo

Coordinator
Jul 8, 2009 at 8:01 AM

what errors are you getting?

Jul 8, 2009 at 9:18 AM

When I open the solution, VS give me varius error in italian... result that all projects are not loaded (gray icons, unloaded status).
I have VS 2008 Developer and Database edition.

Riccardo

 

Jul 8, 2009 at 11:38 AM

I find this warning in CodePlex site:

!! Warning !! - If you use the Team Explorer client then it will add source control binding information into your project files. When users download your source code and try to open it in Visual Studio they will get error messages because of the source control bindings. You can use any of the other available source control clients as an alternative.

My be it is the problem! I don't have installed Team Explorer.
If my suppose is right, you could delivery the source files after remove the source control binding.

Is not my intention, to install Team Explorer and is not necessary for many people to do.

Riccardo

 

 

Jul 13, 2009 at 9:12 AM
Edited Jul 13, 2009 at 9:45 AM

I can't compile the latest version (26611) either.

I don't have TFS installed, and I did get a warning saying the source control would be offline.

My problem when building is I get multiple errors saying that certain types are missing.

Error    1    The type or namespace name 'Grammar' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\LanguageData.cs    8    21    010.Irony

Error    3    The type or namespace name 'LanguageData' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\Parser\Parser.cs    9    21    010.Irony

Error    4    The type or namespace name 'GrammarData' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\LanguageData.cs    9    21    010.Irony

Error    8    The type or namespace name 'LR0ItemSet' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\Construction\ParserDataBuilder_NonCanonical.cs    10    5    010.Irony

Once I fixed all the missing namespaces, I got the following errors.

Error    1    The type or namespace name 'TokenEventArgs' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\CompilerContext.cs    85    31    010.Irony

Error    2    The type or namespace name 'TokenEventArgs' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\CompilerContext.cs    86    5    010.Irony

Error    3    The type or namespace name 'AstNodeEventArgs' could not be found (are you missing a using directive or an assembly reference?)    D:\src\Irony\Irony\Parsing\Grammar\BnfTerm.cs    113    31    010.Irony

Error    4    The type or namespace name 'LR0ItemList' does not exist in the namespace 'Irony.Parsing.Construction' (are you missing an assembly reference?)    D:\src\Irony\Irony\Parsing\Parser\ParserData.cs    131    36    010.Irony

Thanks

Cameron

Edit: I found the problem. Some of the classes were still referencing the CompilerServices namespace instead of the Parsing one. I've submitted a patch to get revision 26611 building. Hope it helps.

Coordinator
Jul 13, 2009 at 4:57 PM

Yes, there's a problem there. Looks like my last checkin didn't go in correctly. Will update it asap

Sorry for trouble

Roman

Coordinator
Jul 13, 2009 at 5:06 PM

Repeated the checkin, downloaded back from Source page, compiled, run - seems to be working now

Sorry again for troubles

Roman

Jul 17, 2009 at 10:54 AM

I have the same problem as rimariot. I used TortoiseSVN to get the latest code from SVN. However when I try to open the solution, I get an error saying the project is under source control, finally all the projects show up as being grayed out. I would rather not use TeamExplorer. Any suggestions ?

Jul 17, 2009 at 11:16 AM

Just disable Visual Studio's source control when opening the solution for the first time. It will ask to remove the version control bindings permanently. After that you can re-enable your source control in VS.

Jul 17, 2009 at 11:50 AM

Thanks MichelangeloPM that worked. For anyone who does not know how to turn off source control in VS, go to Tools-->Options. Next select Source-Control-->Plug-in Selection  and choose None from the  "Current source control plug-in" drop box.